Outgoing call issue

Incident Report for TeligentIP

Postmortem

Executive Summary

The purpose of this document is to provide an assessment of the issue with outgoing calls on Saturday, 5/10/2025.

Timeline of issue and root cause:

We received reports regarding outgoing call failures at approximately 10:15 AM PST.

Our engineering team was engaged, and we started troubleshooting. We determined that there was a routing issue between the PSX (the routing engine) and the SBC (Session Border Controller). Our engineering team worked closely with the SCB vendor to isolate the root cause. It was determined that an invalid STIR/SHAKEN certificate created the issue with outgoing calls. Our team bypassed the certificate, and outgoing calls resumed normal behavior at approximately 2:15 PM PST.

Corrective Action:

We worked with the vendor and obtained a correct certificate and applied it to our SBC the following night during a maintenance window. Additionally, we made sure that the vendor will send proper notifications moving forward to prevent this issue in the future.

Posted May 13, 2025 - 13:59 CST

Resolved

This incident has been resolved. We will work with the involved parties and provide an RFO when it becomes available.
Posted May 10, 2025 - 15:46 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 10, 2025 - 15:18 CST

Identified

The issue has been identified and a fix is being implemented.
Posted May 10, 2025 - 15:18 CST

Update

Our NOC engineers have isolated the problem and are continuing to work with all required parties to restore outbound service immediately. Again, we appreciate your patience in this matter and will have another update soon.

Thank you,

TeligentIP Support Team
1-855-IPITIMI (474-8464)
support@teligentip.com
Posted May 10, 2025 - 15:01 CST

Update

Our engineers are continuing to work diligently with all parties involved to restore impacted services as soon as possible. We appreciate your patience through this process and will provide an update as soon as we can. We currently do not have an ETA, but this ticket is already escalated to the highest priority.
Posted May 10, 2025 - 13:39 CST

Update

We are continuing to investigate this issue.
Posted May 10, 2025 - 13:12 CST

Update

Our engineers are continuing to work diligently with all parties involved to restore impacted services as soon as possible. We appreciate your patience through this process and will provide an update as soon as we can.



Thank you,

TeligentIP Support Team
1-855-IPITIMI (474-8464)
support@teligentip.com
Posted May 10, 2025 - 12:26 CST

Investigating

We are currently experiencing an issue with outgoing calls and are working with our vendor to resolve this as soon as possible and will provide an update.
Posted May 10, 2025 - 12:11 CST
This incident affected: Session Border Controllers (ORD Datacenter (Primary)).