Our monitoring systems are indicating network problems that can result in service interruptions in your area.

Incident Report for TeligentIP

Postmortem

Incident Window Start: 2026-03-03 13:02 UTC End: 2026-03-03 14:43 UTC

 

Impacted Services:

A subset of US customer voice traffic was unable to reach the inbound carrier’s network due to misrouted internet traffic which resulted in inbound call failures for affected customers.

 

Summary:

At 13:02 UTC, a global network carrier experienced a routing issue that temporarily affected connectivity between portions of the public internet and several downstream telephone carriers, including TeligentIP. During this routing issue, TeligentIP's network, and routing remained stable and in production, however some customers accessing voice services that their ISP routed through these internet routing paths may have experienced intermittent connectivity issues.

The global carrier’s engineering teams have reported back the findings of the routing issue and determined that the disruption was caused in their network by an external route leak. A newly established network peering relationship resulted in a peer network unintentionally re-advertising the provider’s IP address ranges to the broader internet. Because these leaked routes appeared more preferable to certain upstream networks, some inbound traffic was incorrectly directed toward the peer network rather than the intended carrier infrastructure. This resulted in partial reachability loss for affected systems.

Once the routing anomaly was identified, the carrier promptly removed the associated peering session to stop the propagation of the leaked routes.

Normal global internet routing converged shortly afterward, and system availability returned to expected levels by 14:43 UTC.

 

Root Cause:

A newly activated interconnection with a peer inadvertently led to the carrier’s IP prefixes being re‑advertised to the public internet. This route leak made their network appear reachable through the peer’s network, causing portions of global internet traffic to follow incorrect paths and become undeliverable for Voice services.

 

Resolutions:

To strengthen service reliability and speed up recovery should this type of issue arise again, our carrier is taking the following actions: ● Applying safeguards to new network turn‑ups to limit propagation of IP prefixes. ● Evaluating automated BGP hijack and route‑leak monitoring tools to detect routing anomalies more quickly.

Posted Mar 10, 2026 - 09:49 CST

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 09:32 CST

Update

We are happy to inform you that all service are restored now and you should be fully operational at this time. Our engineers will continue to monitor the network and provide root-cause analysis as soon as it becomes available.
Posted Mar 03, 2026 - 09:32 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 09:09 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 03, 2026 - 08:59 CST

Investigating

Our monitoring systems are indicating network problems that can result in service interruptions in your area. Our NOC engineers are currently working with our partners to resolve the issue as soon as possible. We apologize for the inconvenience this is causing but please be rest assured that we have engaged all our resources in this matter. We will provide updates as we progress.
Posted Mar 03, 2026 - 08:06 CST
This incident affected: Session Border Controllers (ORD Datacenter (Primary), IAD Datacenter (Secondary)).